Çözüldü Arch'ta "Error: file '/boot/vmlinuz-linux' not found arch" hatası

Bu konu çözüldü olarak işaretlenmiştir. Çözülmediğini düşünüyorsanız konuyu rapor edebilirsiniz.
Çözüm
Gece paketleri güncelleştiriyordum 1GB iniyordu ama nedensizce bilgisayarı kapattım. Şu an açamıyorum. Elimde Arch USB'si var.
Bilgisayari USB'den ac ve arch-chroot ol bolumleri mount edip. Daha sonra pacman -S linux yap yeniden kur. Bir de mkinitcpio -P yap. Sonra grub-mkconfig -o /boot/grub/grub.cfg yap ve yeniden baslat. (Boot ve root bolumlerini mount etmeyi unutma!)
KS
KS
Vergi Kaçakçısı
Katılım
12 Mayıs 2020
Mesajlar
2.156
Makaleler
1
Çözümler
10
Yer
papua yeni gine
GRUB kurulu muydu?.. GRUB gitmis galiba nasil bir anda kapattiysan. O klasoru sil, hatta bence mkfs.vfat -F32 /dev/sdxy yap. X diskinin harfi y de boot diskinin numarasi olacak sekilde. Boot'taki her sey silinsin, sonra tekrar mount et boot bolumunu ve Linux kerneli + GRUB kur.
Yaptım ama tekrar hata verdi grub'da.
 
KS
KS
Vergi Kaçakçısı
Katılım
12 Mayıs 2020
Mesajlar
2.156
Makaleler
1
Çözümler
10
Yer
papua yeni gine
Aynisi mi? FAT32 olarak bicimlendirdigine ve mount ettigine eminsindir umarim. lsblk ciktisi atar misin?
Evet aynısını yaptım. 5dk bilgisayarı açayım kapatmıştım.

Şuan bambaşka hatalar geliyor. Pacman - S linux yazdığımda <> exists in file system diyor.

@Linuxginar
 
Son düzenleme:
KS
KS
Vergi Kaçakçısı
Katılım
12 Mayıs 2020
Mesajlar
2.156
Makaleler
1
Çözümler
10
Yer
papua yeni gine

Dosya Ekleri

  • 16607709905566624054992509088958.jpg
    16607709905566624054992509088958.jpg
    72,6 KB · Görüntüleme: 6
Son düzenleme:

Linuxginar

Megapat
Katılım
4 Temmuz 2017
Mesajlar
7.243
Makaleler
6
Çözümler
128
Yer
Izmir
mkinit'te de preset not found in/etc/mkinitcpio.d diyor.


'Linux' requried by broadcam-wl diyor.

Chroot'ta değilmişim pardon 😅 tekrar deniyorum.

@Linuxginar
/boot mount edilmis. Linux'u kur, grub-install ile normal kurdugun gibi GRUB kur, sonra grub-mkconfig -o /boot/grub/grub.cfg yap. Sistemi yeniden baslat.
 
KS
KS
Vergi Kaçakçısı
Katılım
12 Mayıs 2020
Mesajlar
2.156
Makaleler
1
Çözümler
10
Yer
papua yeni gine
/boot mount edilmis. Linux'u kur, grub-install ile normal kurdugun gibi GRUB kur, sonra grub-mkconfig -o /boot/grub/grub.cfg yap. Sistemi yeniden baslat.
Efi klasörü bulunamadı diyor.

Umount ile /boot'tan çıkarıp /boot/efi bağladım oldu.
 
Son düzenleme:
Yukarı