Klon Arduino bağlantısı kesiliyor

berk9977

Centipat
Katılım
8 Ocak 2021
Mesajlar
16
Merhaba. Arduino kodlamaya başladım fakat orijinal Arduino cok pahalı oldugu icin klon aldım ve joystick ile kontrol edilen servo motor sistemi yaptım. Sistem calısıyor ama calıstıktan 7-8 sn sonra Windows USB cıkarma sesi geliyor ve sistemde guc olsa bile hareket ettiremiyorum. Pil ile calıstırdım ama yine aynı olay. Reset tusuna bastıgımda calısıyor fakat 6-7 sn sonra yine aynı olay.
 

Kızılsakal34

Decapat
Katılım
13 Ağustos 2019
Mesajlar
553
Çözümler
5
Bu kartı kaç kere hangi projelerde kullandınız? Bir şekide bozmış olabilir misin?
Birde içerisine led yakan söndüren bir kod yazıp onunla denermisin
 

ulpian

Picopat
Katılım
11 Ekim 2021
Mesajlar
388
Çözümler
6
Servo motoru doğrudan Arduino üzerinden sürüyorsanız güç yetmiyor olabilir. Arduino'ya blink kodunu yükleyip aynı durumun devam edip etmediğini test ettiniz mi?
 
KS
KS
B

berk9977

Centipat
Katılım
8 Ocak 2021
Mesajlar
16
Bu kartı kaç kere hangi projelerde kullandınız? Bir şekide bozmış olabilir misin?
Birde içerisine led yakan söndüren bir kod yazıp onunla denermisin
Daha dün geldi sadece blink calıstırdım ve servo motor dondurdum.
Simdi blink upload ettim ve sorunsuz calısıyor
Servo motoru doğrudan Arduino üzerinden sürüyorsanız güç yetmiyor olabilir. Arduino'ya blink kodunu yükleyip aynı durumun devam edip etmediğini test ettiniz mi?
İlge İpek in robotistana cektiği videoya bakarak yaptım orda calısıyordu. Blink su an sorunsuz calısıyor.
 

await

Picopat
Katılım
2 Ocak 2022
Mesajlar
99
Çözümler
4
USB chip'inin sorunlu olduğunu düşünüyorum ben. Klon arduino'larda CH340 kullanılıyordu yanlış hatırlamıyorsam. Biraz sıkıntılı bir chip. Driver sıkıntısı olma ihtimalini yok etmek için netten CH340 driverlarını arayıp indirmelisin. Çalışacağını pek düşünmesem de denemekten zarar gelmez.

Eğer çalışmazsa dediğim gibi USB chip'i sıkıntılı olabilir. Satın aldığın yere iade edip yenisini talep edebilirsin.
 
KS
KS
B

berk9977

Centipat
Katılım
8 Ocak 2021
Mesajlar
16
USB chip'inin sorunlu olduğunu düşünüyorum ben. Klon arduino'larda CH340 kullanılıyordu yanlış hatırlamıyorsam. Biraz sıkıntılı bir chip. Driver sıkıntısı olma ihtimalini yok etmek için netten CH340 driverlarını arayıp indirmelisin. Çalışacağını pek düşünmesem de denemekten zarar gelmez.

Eğer çalışmazsa dediğim gibi USB chip'i sıkıntılı olabilir. Satın aldığın yere iade edip yenisini talep edebilirsin.
CH340 indirdim baska bir usb ile deniyim
Baska bir tane usb ile denedim sorun cozuldu.
 
Son düzenleme:

İbrahim Zdemir

Terapat
Sosyal Tayfı
Katılım
2 Haziran 2015
Mesajlar
13.605
Makaleler
107
Çözümler
119
USB çipi değil @ulpian ın da bahsettiği gibi güç ile alakalı bir sorun. Klon Arduino'ların hemen hemen hepsinde AS1117 regülatör bulunuyor ve bu regülatör bir ya da daha fazla servo bağlayınca yetersiz kalıyor.

Servoları ayrı bir güç hattına bağlayarak dene, 5V.
 
KS
KS
B

berk9977

Centipat
Katılım
8 Ocak 2021
Mesajlar
16
USB çipi değil @ulpian ın da bahsettiği gibi güç ile alakalı bir sorun. Klon Arduino'ların hemen hemen hepsinde AS1117 regülatör bulunuyor ve bu regülatör bir ya da daha fazla servo bağlayınca yetersiz kalıyor.

Servoları ayrı bir güç hattına bağlayarak dene, 5V.
Evet sonradan farkettim 3.3 v baglayınca servoya duzgun bir sekilde calısıyor. Peki 5v takıp direnç taksam olurmu.
 

İbrahim Zdemir

Terapat
Sosyal Tayfı
Katılım
2 Haziran 2015
Mesajlar
13.605
Makaleler
107
Çözümler
119
Olay 3.3V ya da 5V ile değil, regülatörün verebildiği max. Amper değeri ile alakalı. Bu nedenle harici güç kaynağına bağlamalısın Servo'ları.

3.3V'ye bağladığında daha az akım çekeceği için çalışıyor ancak günün sonunda Servon daha güçsüz olacak.
 
Yukarı