Bu konu bir çözümü açıklamaktadır. Herhangi bir çözüm açıklanmadığını düşünüyorsanız konuyu rapor edebilirsiniz.
Durum
Mesaj gönderimine kapalı.
382725


Bu uygulanacak işlemler ile AMD işlemciye sahip macOS kullanıcılar Adobe CC uygulamalarının açılmama/hata/crash/çökme gibi sorunlarını çözeceklerdir.

Adımlar​

  1. Adobe Creative Cloud'dan ihtiyacınız olan Adobe uygulamalarını yükleyin.
  2. Terminal'i açın.
  3. Aşağıdaki komutu, Terminal'e kopyalayıp-yapıştırın ve çalıştırın (şifreniz sorulduğunda girin).

    Kod:
    files_list=(MMXCore FastCore TextModel libiomp5.dylib)
    lib_dir="${HOME}/Documents/AdobeLibs"
    lib1_file="${lib_dir}/libiomp5.dylib"
    lib1_link="https://raw.githubusercontent.com/naveenkrdy/Misc/master/Libs/libiomp5.dylib"
    
    for file in $files_list; do
        find /Applications/Adobe* -type f -name $file | while read -r curr_file; do
            name=$(basename $curr_file)
            sw_vers -productVersion | grep "11" >/dev/null 2>&1
            [[ $? == 0 ]] && [[ $name =~ ^(MMXCore|FastCore)$ ]] && continue
            echo "found $curr_file"
            sudo -v
            [[ ! -f ${curr_file}.back ]] && sudo cp -f $curr_file ${curr_file}.back || sudo cp -f ${curr_file}.back $curr_file
            if [[ $name == "libiomp5.dylib" ]]; then
                [[ ! -d $lib_dir ]] && mkdir $lib_dir
                [[ ! -f $lib1_file ]] && cd $lib_dir && curl -sO $lib1_link
                adobelib_dir=$(dirname "$curr_file")
                echo -n "replacing " && sudo cp -vf $lib1_file $adobelib_dir
            elif [[ $name == "TextModel" ]]; then
                echo "emptying $curr_file"
                sudo echo -n >$curr_file
            else
                echo "patching $curr_file"
                sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg' $curr_file
                sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x4A\x00|\x90\x90\x90\x90\x56\xE8\x1A\x00|sg' $curr_file
            fi
        done
    done
  4. Şimdi tekrar aşağıdaki komutu Terminal'e kopyalayıp-yapıştırın ve çalıştırın (şifreniz sorulduğunda girin).

    Kod:
    agent_dir="${HOME}/Library/LaunchAgents"
    env_file="${agent_dir}/environment.plist"
    lib_dir="${HOME}/Documents/AdobeLibs"
    lib2_file="${lib_dir}/libfakeintel.dylib"
    lib2_link="https://raw.githubusercontent.com/naveenkrdy/Misc/master/Libs/libfakeintel.dylib"
    
    sw_vers -productVersion | grep "11" >/dev/null 2>&1
    if [[ $? == 0 ]]; then
        [[ ! -d $lib_dir ]] && mkdir $lib_dir
        [[ ! -f $lib2_file ]] && cd $lib_dir && curl -sO $lib2_link
        env="launchctl setenv DYLD_INSERT_LIBRARIES $lib2_file"
    else
        mkl_value=$(
            sysctl -n machdep.cpu.brand_string | grep FX >/dev/null 2>&1
            echo $(($? != 0 ? 5 : 4))
        )
        env="launchctl setenv MKL_DEBUG_CPU_TYPE $mkl_value"
    fi
    
    [[ ! -d $agent_dir ]] && mkdir $agent_dir
    cat >$env_file <<EOF
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>Label</key>
    <string>mkl-debug</string>
    <key>ProgramArguments</key>
    <array>
    <string>sh</string>
    <string>-c</string>
        <string>$env;</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    </dict>
    </plist>
    EOF
    
    launchctl load ${AGENT} >/dev/null 2>&1
    launchctl start ${AGENT} >/dev/null 2>&1
  5. macOS'u yeniden başlatın.

Yapılan Adımları Geri Çevirmek​

Yapılanları geri çevirmek için aşağıdaki komutu gerektiği gibi çalıştırın.
  • 3.adımı geri çevirmek için:
    Kod:
    files_list=(MMXCore FastCore TextModel libiomp5.dylib)for file in $files_list; do
        find /Applications/Adobe* -type f -name $file | while read -r curr_file; do
            sudo -v
            [[ -f ${curr_file}.back ]] && echo "Restoring backup $curr_file"&& sudo mv -f ${curr_file}.back $curr_file
        done
    done
  • 4.adımı geri çevirmek için:
    Kod:
    agent_dir="${HOME}/Library/LaunchAgents"env_file="${agent_dir}/environment.plist"
    if [[ -f $env_file ]]; then
        echo "Deleting $env_file"
        launchctl unload ${env_file} >/dev/null 2>&1
        launchctl stop ${env_file} >/dev/null 2>&1
        rm -rf $env_file
    fi
  • macOS'u yeniden başlatın.

Kaynakça: To fix adobe products crashes on AMD hackintosh
 
Son düzenleyen: Moderatör:
Güncel bilgiler.
Kod:
USAGE : Open terminal and run the below commands as required.

Photoshop crash fix :-
PS2018

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x5A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Photoshop\ CC\ 2018/Adobe\ Photoshop\ CC\ 2018.app/Contents/Required/Plug-ins/Extensions/MMXCore.plugin/Contents/MacOS/MMXCore
sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x5A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Photoshop\ CC\ 2018/Adobe\ Photoshop\ CC\ 2018.app/Contents/Required/Plug-ins/Extensions/FastCore.plugin/Contents/MacOS/FastCore
PS2019

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Photoshop\ CC\ 2019/Adobe\ Photoshop\ CC\ 2019.app/Contents/Required/Plug-ins/Extensions/MMXCore.plugin/Contents/MacOS/MMXCore
sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Photoshop\ CC\ 2019/Adobe\ Photoshop\ CC\ 2019.app/Contents/Required/Plug-ins/Extensions/FastCore.plugin/Contents/MacOS/FastCore

Photoshop Font crash fix :-
PS2018

sudo rm -rf /Applications/Adobe\ Photoshop\ CC\ 2018/Adobe\ Photoshop\ CC\ 2018.app/Contents/Required/Deep_Font
PS2019

sudo rm -rf /Applications/Adobe\ Photoshop\ CC\ 2019/Adobe\ Photoshop\ CC\ 2019.app/Contents/Required/Deep_Font

Photoshop image open , drag-n-drop and image size change crash fix :-
sudo rm -rf /Library/Application\ Support/Adobe/Plug-Ins/CC/File Formats/Camera\ Raw.plugin
~OR~
Use Camera Raw 9.12.1
http://download.adobe.com/pub/adobe/photoshop/cameraraw/mac/9.x/CameraRaw_9_12_1_mac.zip

Illustrator crash fix :-
IL2018

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x5A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Illustrator\ CC\ 2018/Adobe\ Illustrator\ CC\ 2018.app/Contents/MacOS/MMXCore.plugin/Contents/MacOS/MMXCore
sudo rm -rf /Applications/Adobe\ Illustrator\ CC\ 2018/Adobe\ Illustrator\ CC\ 2018.app/Contents/Required/Plug-ins/Text\ Filters/TextModel.aip
IL2019

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Illustrator\ CC\ 2019/Adobe\ Illustrator.app/Contents/MacOS/MMXCore.plugin/Contents/MacOS/MMXCore
sudo rm -rf /Applications/Adobe\ Illustrator\ CC\ 2019/Adobe\ Illustrator.app/Contents/Required/Plug-ins/Text\ Filters/TextModel.aip

Bridge crash fix :-
BR2018

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Bridge\ CC\ 2018/Adobe\ Bridge\ CC\ 2018.app/Contents/Plug-ins/MMXCore.plugin/Contents/MacOS/MMXCore
BR2019

sudo perl -i -pe ‘s|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg’ /Applications/Adobe\ Bridge\ CC\ 2019/Adobe\ Bridge\ 2019.app/Contents/Plug-Ins/MMXCore.plugin/Contents/MacOS/MMXCore

After Effects crash fix :-
sudo rm -rf /Library/Application\ Support/Adobe/Plug-Ins/CC/File Formats/Camera\ Raw.plugin
~OR~
Use Camera Raw 9.12.1
 
Daha önce bende sorunsuz çalışıyordu. Şimdi ise açılması vs normal ama direk Completed uyarısı veriyor ve patchlememiş oluyor. Önceden uygulamayı patchlemek için izin sorardı. Sistemim Mojave 10.14.2.
 
Durum
Mesaj gönderimine kapalı.

Yeni konular

Geri
Yukarı