Python Selenium "Module not found" hatası

John Worthy

Kilopat
Katılım
1 Mart 2013
Mesajlar
580
Çözümler
1
Selenium yuklemeye calisiyorum. Stackoverflow ve bir sürü siteye girdim. Klasik pip3 install Selenium Python3 install Selenium vs. vs. bir sıkıntı var bu iste. Derse baslayacagim ama no module found hatasindan Udemy'den aldigim kursu saldim. Simdi modulu calistirmaya calisiyorum. Yalniz VS Code(macOS)'te yukledim. Altinda cizgi yok. Terminal'e ya da Console'a yazinca: "requirement already satisfied" diyor. Tahminimce bir path olayi onu da anladim ama macOS"te bunu cozemiyorum. Simdi iki tane interpreter var VS Code'da 3.9 Python ve 3.10. Ben zaten 3.10'a yukledim. Terminalden listelerede baktim yuklu. Sifasi var mi bu hastaligin?

pip3 install selenium Requirement already satisfied: selenium in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (4.5.0) Requirement already satisfied: trio~=0.17 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from selenium) (0.22.0) Requirement already satisfied: urllib3[socks]~=1.26 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from selenium) (1.26.12) Requirement already satisfied: certifi>=2021.10.8 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from selenium) (2022.9.14) Requirement already satisfied: trio-websocket~=0.9 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from selenium) (0.9.2) Requirement already satisfied: attrs>=19.2.0 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (22.1.0) Requirement already satisfied: sniffio in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (1.3.0) Requirement already satisfied: sortedcontainers in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (2.4.0) Requirement already satisfied: async-generator>=1.9 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (1.10) Requirement already satisfied: exceptiongroup>=1.0.0rc9 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (1.0.0rc9) Requirement already satisfied: idna in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (3.4) Requirement already satisfied: outcome in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio~=0.17->selenium) (1.2.0) Requirement already satisfied: wsproto>=0.14 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from trio-websocket~=0.9->selenium) (1.2.0) Requirement already satisfied: PySocks!=1.5.7,<2.0,>=1.5.6 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from urllib3[socks]~=1.26->selenium) (1.7.1) Requirement already satisfied: h11<1,>=0.9.0 in /Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages (from wsproto>=0.14->trio-websocket~=0.9->selenium) (0.14.0)
 
Son düzenleme:
KS
KS
John Worthy

John Worthy

Kilopat
Katılım
1 Mart 2013
Mesajlar
580
Çözümler
1
Terminali açıp "pip install --upgrade pip" yazmayı dener misiniz?
SImdi bunu cozdum, lakin valla nasil yaptigimi bile anlamadim ama birsekilde oldu. Pip3 yada python3 ile oldu. Simdi ki problemim hocanin dedigi herseyi birebir yaptim ama aldigim : "Message: 'Day 48' executable needs to be in PATH. Please see ChromeDriver - WebDriver for Chrome".

Ben bunu path'e koyuyorum. Kod soyle:

Kod:
from selenium import webdriver

chrome_driver= "Users/hageshiku/Desktop/Day 48"

driver = webdriver.Chrome(executable_path=chrome_driver)

driver.get("https://www.amazon.com")

Google Chrome Version = Version 106.0.5249.91 (Official Build) (arm64)

Ben burda : ChromeDriver - WebDriver for Chrome - Downloads benimkinin birebir aynisini bulamadim ama ordan 106 yukleyin diyor. 106'ya girip ARM64 supportluyu indirdim. Google Chrome'uda updateledim.
 

SirY

Centipat
Katılım
7 Aralık 2020
Mesajlar
288
Daha fazla  
Cinsiyet
Erkek
SImdi bunu cozdum, lakin valla nasil yaptigimi bile anlamadim ama birsekilde oldu. Pip3 yada python3 ile oldu. Simdi ki problemim hocanin dedigi herseyi birebir yaptim ama aldigim : "Message: 'Day 48' executable needs to be in PATH. Please see ChromeDriver - WebDriver for Chrome".

Ben bunu path'e koyuyorum. Kod soyle:

Kod:
from selenium import webdriver

chrome_driver= "Users/hageshiku/Desktop/Day 48"

driver = webdriver.Chrome(executable_path=chrome_driver)

driver.get("https://www.amazon.com")

Google Chrome Version = Version 106.0.5249.91 (Official Build) (arm64)

Ben burda : ChromeDriver - WebDriver for Chrome - Downloads benimkinin birebir aynisini bulamadim ama ordan 106 yukleyin diyor. 106'ya girip ARM64 supportluyu indirdim. Google Chrome'uda updateledim.
Oldu yani?
 
KS
KS
John Worthy

John Worthy

Kilopat
Katılım
1 Mart 2013
Mesajlar
580
Çözümler
1
webdriver.Chrome (service=Service (ChromeDriverManager ( ).install ( )))

Bunu kullanırsanız otomatik olarak kendisi iner.
Hocam simdiden kusuruma bakmayin eger noob bir soruysa. Yeniyim bu iste. Suan boyle oluyor. Klasik sekilde yaptigimda ise nedense chromedriver dosyada calismiyor. VSCODE'da yeni sayfa acip yeni file acip oyle yazarsam calisiyor. Sacma sapan bir mevzu anlamadim.
 

Dosya Ekleri

  • Screen Shot 2022-10-18 at 17.38.58.png
    Screen Shot 2022-10-18 at 17.38.58.png
    81,6 KB · Görüntüleme: 9

Maxtoric

Centipat
Katılım
31 Mayıs 2021
Mesajlar
611
Çözümler
6
Daha fazla  
Cinsiyet
Erkek
Hocam simdiden kusuruma bakmayin eger noob bir soruysa. Yeniyim bu iste. Suan boyle oluyor. Klasik sekilde yaptigimda ise nedense chromedriver dosyada calismiyor. VSCODE'da yeni sayfa acip yeni file acip oyle yazarsam calisiyor. Sacma sapan bir mevzu anlamadim.
from selenium.webdriver.chrome.service import Service
from webdriver_manager.chrome import ChromeDriverManager
 
Yukarı