Program yüklemeye çalışırken terminal hatası

Repeat

Decapat
Katılım
2 Eylül 2021
Mesajlar
73
Daha fazla  
Cinsiyet
Erkek
Bir program yüklemek istediğimde, "sudo apt install refind" diyorum mesela ve bana

"Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bu sorunları düzeltmek için 'apt --fix-broken install' komutunu çalıştırmanız gerekebilir.
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:

libgl1-mesa-dri:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
Tavsiye ettikleri: libgl1-amber-dri:i386 ama kurulabilir değil

libosmesa6:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-va-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-vdpau-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-vulkan-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
N: '/etc/apt/sources.list.d/' dizinindeki 'ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
E: Karşılanmamış bağımlılıklar. 'apt --fix-broken install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin)."


hatasını veriyor. (bu bütün uygulamalarda oluyor.) Genelde tüm internette yazan şeyler genelde "apt --fix-broken install" komudunu kullan oluyor fakat, o komudu kullandığımda ise bana şu hatayı veriyor:

"N: '/etc/apt/sources.list.d/' dizinindeki 'ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
E: Kilit dosyası /var/lib/dpkg/lock-frontend açılamadı - open (13: Erişim engellendi)
E: dpkg önyüzü (/var/lib/dpkg/lock-frontend) kilitlenemiyor, root kullanıcısı mısınız?"

Ayrıca yapay zekaya sorduğumda bana "sudo apt --fix-broken install" kodunu veriyor ama onda şöyle bir hata alıyorum

"Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
libatomic1:i386 libdrm-nouveau2:i386 libllvm17t64 libllvm17t64:i386
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
libllvm18:i386
Aşağıdaki YENİ paketler kurulacak:
libllvm18:i386
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 12 paket yükseltilmeyecek.
6 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/31,8 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 140 MB ek disk alanı kullanılacak.
N: '/etc/apt/sources.list.d/' dizinindeki 'ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
Devam etmek istiyor musunuz? [E/h] e
N: '/etc/apt/sources.list.d/' dizinindeki 'ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
(Veritabanı okunuyor ... 154451 dosya veya dizin kurulu durumda.)
Paket açılacak: .../libllvm18_1%3a18.1.3-1_i386.deb ...
Paket açılıyor: libllvm18:i386 (1:18.1.3-1) ...
dpkg: /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb arşivi işlenirken
sorun yaşandı (--unpack):

paylaşılan '/usr/lib/llvm-18/lib/libLLVM.so.1' dosyasının üzerine yazılmaya çal
ışılıyor, dosya libllvm18:i386 paketinin diğer örneklerinden farklı
İşleme sırasında hatalarla karşılaşıldı:

/var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"


Nasıl çözerim?
 
Bir program yüklemek istediğimde, "sudo apt install refind" diyorum mesela ve bana

"Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bu sorunları düzeltmek için 'apt --fix-broken install' komutunu çalıştırmanız gerekebilir.
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:

libgl1-mesa-dri:i386 : Bağımlılıklar: Libllvm18:i386 ama kurulmayacak
Tavsiye ettikleri: Libgl1-amber-dri:i386 ama kurulabilir değil
libosmesa6:i386 : Bağımlılıklar: Libllvm18:i386 ama kurulmayacak
mesa-VA-drivers:i386 : Bağımlılıklar: Libllvm18:i386 ama kurulmayacak
mesa-vdpau-drivers:i386 : Bağımlılıklar: Libllvm18:i386 ama kurulmayacak
mesa-Vulkan-drivers:i386 : Bağımlılıklar: Libllvm18:i386 ama kurulmayacak
N: '/etc/apt/sources.list.d/' dizinindeki 'Ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
E: Karşılanmamış bağımlılıklar. 'apt --fix-broken install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin)."


Hatasını veriyor. (bu bütün uygulamalarda oluyor.) Genelde tüm internette yazan şeyler genelde "apt --fix-broken install" komudunu kullan oluyor fakat, o komudu kullandığımda ise bana şu hatayı veriyor:

"N: '/etc/apt/sources.list.d/' dizinindeki 'Ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
E: Kilit dosyası /var/lib/dpkg/lock-frontend açılamadı - open (13: Erişim engellendi)
E: Dpkg önyüzü (/var/lib/dpkg/lock-frontend) kilitlenemiyor, root kullanıcısı mısınız?"

Ayrıca yapay zekaya sorduğumda bana "sudo apt --fix-broken install" kodunu veriyor ama onda şöyle bir hata alıyorum

"Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:

Libatomic1:i386 libdrm-nouveau2:i386 libllvm17t64 libllvm17t64:i386
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:

Libllvm18:i386
Aşağıdaki YENİ paketler kurulacak:

Libllvm18:i386
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 12 paket yükseltilmeyecek.
6 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/31,8 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 140 MB ek disk alanı kullanılacak.
N: '/etc/apt/sources.list.d/' dizinindeki 'Ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
Devam etmek istiyor musunuz? [E/h] e
N: '/etc/apt/sources.list.d/' dizinindeki 'Ubuntu.sources.curtin.orig' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
(Veri tabanı okunuyor ... 154451 dosya veya dizin kurulu durumda.)
Paket açılacak: .../libllvm18_1%3a18.1.3-1_i386.deb ...
Paket açılıyor: Libllvm18:i386 (1:18.1.3-1) ...
Dpkg: /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb arşivi işlenirken
Sorun yaşandı (--unpack):

paylaşılan '/usr/lib/llvm-18/lib/libLLVM.so.1' dosyasının üzerine yazılmaya çal
Işılıyor, dosya libllvm18:i386 paketinin diğer örneklerinden farklı
İşleme sırasında hatalarla karşılaşıldı:

/var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"


Nasıl çözerim?

Güncellemeyi denediniz mi?

sudo apt update
 
/etc/apt/sources.list.d/ Dizininde 'ubuntu.sources.curtin.orig' dosyasının uzantısını .org olarak değiştirip deneyin.
 
Dosyayı silip tekrar dene.
Denedim yine olmadı.

Dosyayı yüklemek istediğimde verdiği hata:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bu sorunları düzeltmek için 'apt --fix-broken install' komutunu çalıştırmanız gerekebilir.
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
libgl1-mesa-dri:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
Tavsiye ettikleri: libgl1-amber-dri:i386 ama kurulabilir değil
libosmesa6:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-va-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-vdpau-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
mesa-vulkan-drivers:i386 : Bağımlılıklar: libllvm18:i386 ama kurulmayacak
E: Karşılanmamış bağımlılıklar. 'apt --fix-broken install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin).

apt --fix-broken install kodu kullandığımda:

E: Kilit dosyası /var/lib/dpkg/lock-frontend açılamadı - open (13: Erişim engellendi)
E: dpkg önyüzü (/var/lib/dpkg/lock-frontend) kilitlenemiyor, root kullanıcısı mısınız?


Dosyayı silip tekrar dene.
Ayrıca sağ üstte şöyle bi' hata var.
1716030785025.png
 
Son düzenleme:
sudo apt --fix-broken install Komudunu deneyin bir de.
 
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
libatomic1:i386 libdrm-nouveau2:i386 libllvm17t64 libllvm17t64:i386
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
libllvm18:i386
Aşağıdaki YENİ paketler kurulacak:
libllvm18:i386
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 12 paket yükseltilmeyecek.
6 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/31,8 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 140 MB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 154451 dosya veya dizin kurulu durumda.)
Paket açılacak: .../libllvm18_1%3a18.1.3-1_i386.deb ...
Paket açılıyor: libllvm18:i386 (1:18.1.3-1) ...
dpkg: /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb arşivi işlenirken
sorun yaşandı (--unpack):
paylaşılan '/usr/lib/llvm-18/lib/libLLVM.so.1' dosyasının üzerine yazılmaya çal
ışılıyor, dosya libllvm18:i386 paketinin diğer örneklerinden farklı
İşleme sırasında hatalarla karşılaşıldı:
/var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
libatomic1:i386 libdrm-nouveau2:i386 libllvm17t64 libllvm17t64:i386
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
libllvm18:i386
Aşağıdaki YENİ paketler kurulacak:
libllvm18:i386
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 12 paket yükseltilmeyecek.
6 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/31,8 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 140 MB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 154451 dosya veya dizin kurulu durumda.)
Paket açılacak: .../libllvm18_1%3a18.1.3-1_i386.deb ...
Paket açılıyor: libllvm18:i386 (1:18.1.3-1) ...
dpkg: /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb arşivi işlenirken
sorun yaşandı (--unpack):

paylaşılan '/usr/lib/llvm-18/lib/libLLVM.so.1' dosyasının üzerine yazılmaya çal
ışılıyor, dosya libllvm18:i386 paketinin diğer örneklerinden farklı
İşleme sırasında hatalarla karşılaşıldı:

/var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo apt autoremove Yazdıktan sonra sudo apt-get clean yazıp tekrar deneyin. Olmassa @Rona hocam yardım edebilir belki.
 

Yeni konular

Yeni mesajlar

Geri
Yukarı