Arduino UNO'ya Kod Yüklenmiyor

Alpaslan64

Hectopat
Katılım
18 Haziran 2019
Mesajlar
1.878
Makaleler
1
Çözümler
7
Arkadaşlar selamlar. Arduino UNO'm dün akşamdan beri garip bir şekilde çalışmıyor. İçine bir türlü kod atamıyorum. Bütün sürücülerini güncelledim, IDE güncelledim. Çıkar-tak yaptım ama yine de olmadı. Normalde güce bilgisayar bağladıktan sonra reset tuşuna basarsam LED'leri sönüp yanardı. Şimdi onlarda tepki vermiyor. Kod atarken de yanıp sönerdi LED'ler ama o zaman da sabit yanıyor. Dediğim gibi bir sürü çözüm denedim ama bir türlü başaramadım. Yardımlarınızı bekliyorum. @Akif9748 @Affansen @İbrahim Zdemir
Hata kodu:

Arduino hata kodu:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x42
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x42
Karta yüklenirken sorun oluştu. Tavsiyeler için http://www.arduino.cc/en/Guide/Troubleshooting#upload adresine göz atabilirsiniz.
 
Son düzenleyen: Moderatör:

cengover_ekin

Hectopat
Katılım
6 Temmuz 2020
Mesajlar
5.262
Makaleler
1
Çözümler
45
12 Saat bekle. Çok büyük ihtimalle düzelir. Sanırsam içindeki elektrik tamamen boşaldığı için resetleniyor bir şekilde. Benzer bir sorunu ben de yaşamıştım.
İçinde pil vs. yok ki. Çok mantıklı gelmedi bu çözüm. Denediniz mi siz ya da kaynağımız var oi bu bilgiyle alakalı?
 
Katılım
30 Eylül 2020
Mesajlar
654
Çözümler
1
Özellikle iletim portlarından ikisini aynı anda kullanınca oluyor bu sorun. Örneğin bluetooth sensörü takılı iken Arduino'ya program yüklemek gibi.
İçinde pil vs. yok ki. Çok mantıklı gelmedi bu çözüm. Denediniz mi siz ya da kaynağımız var oi bu bilgiyle alakalı?
Aynısı kendi başıma geldiğinde böyle çözülmüştü.

İçinde pil değil ama ram belleği var. Mesela Arduino'nun elektriğini söküp tekrar takarsanız içindeki kodun hala aktif olacağını görürsünüz. Ama 12 saat bekleyince o kod da siliniyor, kast ettiğim buydu.
 

Affansen

Hectopat
Katılım
17 Nisan 2020
Mesajlar
4.719
Makaleler
1
Çözümler
29
Size uygun rehberi paylaşıyorum. Oradan yeni bootloader yükleyin. Sorun çözülecektir.
 

İbrahim Zdemir

Terapat
Sosyal Tayfı
Katılım
2 Haziran 2015
Mesajlar
13.588
Makaleler
107
Çözümler
119
Size uygun rehberi paylaşıyorum. Oradan yeni bootloader yükleyin. Sorun çözülecektir.

Aynı hatalar değil. Senin hatanda Bootloader corrupt olmuştu, bunda ise donanımsal bir arıza olabilir ya da USB kablosunda bir sıkıntı olabilir.
 
Yukarı