Çözüldü Arch Linux mikrofon çalışmıyor

Bu konu çözüldü olarak işaretlenmiştir. Çözülmediğini düşünüyorsanız konuyu rapor edebilirsiniz.

Huso112

Picopat
Katılım
26 Ocak 2021
Mesajlar
821
Çözümler
2
Yer
Arch Linux x64 KDE
Merhabalar.
Her şey çok güzel idi...
Sabahleyin Audacity ile ses düzenlemesi yapıyordum. Düzenleme bittikten sonra ffmpeg ile sesi M4A şeklinde aktarmak istemiştim ama Audacity sesi çıkarırken ffmpeg ile ilgili hata veriyordu.
O arada sorunu arada sorunu anlamak için sesimi kaydetmek istemiştim ki... Sesim yoktu.
Bu lanet arıza yüzünden kaç distro, kaç fresh install yaptım ki aklınız durar. Bu yüzden ilk:

Pacmd set-Source-port alsa_input. PCI-0000_00_1b.0.analog-stereo analog-input-Mic

Komutunu, ardından:

Pulseaudio -k
Pulseaudio —start

Komutlarını çalıştırdım. Tabi bu arada Ffmpeg'i de yeniden kurdum ve bir hışımla Audacity'i -rncs bayrağı ile sildim. Yay'de de sonuç aynı olunca orada da bir hışımla sildim.

1. komut çalışmadı. Zaten o alsa içinmiş. 2. komut ise çalıştı.

Reboot yapınca tekrar sesim gelmişti. Çok mutlu olmuştum.

Akşam “belki Audacity düzelmiştir” dedim ve indirdim. Sesimi kaydetmeye çalışınca sonuç eskisine döndü ve 1. ile 2. komutlar sonuç vermedi (evet bu arada Ffmpeg'i yeniden kurmayı unutmuşum. Şimdi deneyemem ana yarın yaparım).

O lanet distro Hopping'e geri dönmek istemiyorum.

Bu arada şu an bilgisayar kapalı ve açamam. Yarın SS ve Pulse. Pa dosyasını eklerim.
 
Çözüm
O eklenen seçenekler geçici, yeniden başlatınca sıfırlanacak onlar. Zaten default.pa dosyasına girdi aygıtı eklenmemiş görünüyor. Bunun yerine aşağıdaki komutla, model=laptop-amic modül değişkeni eklemeyi dene, sonra sistemini yeniden başlatırsın.

Kod:
/bin/bash -c "echo 'options snd-hda-intel model=laptop-amic' | sudo tee /etc/modprobe.d/laptop-amic.conf"

Bu işe yaramazsa, aşağıdaki komutu deneyip sistemi yeniden başlatırsın.

Kod:
/bin/bash -c "echo 'options snd-hda-intel model=laptop-dmic' | sudo tee /etc/modprobe.d/laptop-amic.conf"

OzgunP

Kilopat
Katılım
2 Ekim 2020
Mesajlar
1.965
Makaleler
2
Çözümler
122
Şunu dene bakalım.

Kod:
killall pulseaudio ; pulseaudio -k ; rm -rf ~/.config/pulse* ;  rm -rf ~/.pulse* ; pulseaudio --start
 
KS
Huso112

Huso112

Picopat
Katılım
26 Ocak 2021
Mesajlar
821
Çözümler
2
Yer
Arch Linux x64 KDE
Şunu dene bakalım.

Kod:
killall pulseaudio ; pulseaudio -k ; rm -rf ~/.config/pulse* ;  rm -rf ~/.pulse* ; pulseaudio --start
Cezam anca bitti. Yarın deneyip hemen bildiririm.
Biraz tuhaf gelecek ama sorun kendi kendine çözülmüş. Garip. Yine de teşekkür ederim :)
Bu çözülmedi olarak kalsın isterseniz. Belki aynı sıkıntıdan olan yazar.

Evet Yine aynı problem oldu. Sizin çözümünüzü denedim ama olmadı.

Screenshot_20210615_132010.png
Screenshot_20210615_132047.png
Screenshot_20210615_132111.png
Screenshot_20210615_132219.png
Screenshot_20210615_132256.png
Screenshot_20210615_132257.png
@Arch or Not , @Awsim , @Alperen İsa Nalbant , @dakovey , @cengover_ekin , @Putinstopia , @endless0 , @Kerem00 hocalarım sizce ne yapabilirim?
 

Dosya Ekleri

  • isimsiz.txt
    5,6 KB · Görüntüleme: 12
Son düzenleme:

cengover_ekin

Hectopat
Katılım
6 Temmuz 2020
Mesajlar
5.229
Makaleler
1
Çözümler
42
Cezam anca bitti. Yarın deneyip hemen bildiririm.
Biraz tuhaf gelecek ama sorun kendi kendine çözülmüş. Garip. Yine de teşekkür ederim :)
Bu çözülmedi olarak kalsın isterseniz. Belki aynı sıkıntıdan olan yazar.

Evet Yine aynı problem oldu. Sizin çözümünüzü denedim ama olmadı.

@Arch or Not , @Awsim , @Alperen İsa Nalbant , @dakovey , @cengover_ekin , @Putinstopia , @endless0 , @Kerem00 hocalarım sizce ne yapabilirim?
Müsait bir zamanda bakayım.
 

OzgunP

Kilopat
Katılım
2 Ekim 2020
Mesajlar
1.965
Makaleler
2
Çözümler
122
pavucontrol kurup giriş aygıtını değiştirmeyi denedin mi?

Bir de şunun çıktısını paylaş bakalım.

Kod:
inxi -SMAaxx
 
Son düzenleme:
KS
Huso112

Huso112

Picopat
Katılım
26 Ocak 2021
Mesajlar
821
Çözümler
2
Yer
Arch Linux x64 KDE
pavucontrol kurup giriş aygıtını değiştirmeyi denedin mi?

Bir de şunun çıktısını paylaş bakalım.

Kod:
inxi -SMAaxx
Kod:
[[email protected] ~]$ inxi -SMAaxx
System:    Host: turbine Kernel: 5.12.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d66dbd53-8d5c-d701-902d-bd538d5cd701 rw loglevel=3 quiet 
           nvidia-drm.modeset=1 
           Desktop: KDE Plasma 5.22.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 81BG v: Lenovo ideapad 320-15IKB serial: <superuser required> Chassis: 
           type: 10 v: Lenovo ideapad 320-15IKB serial: <superuser required> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40679 WIN serial: <superuser required> UEFI: LENOVO v: 6JCN33WW 
           date: 06/30/2020 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.10-arch1-1 running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.30 running: yes
 
Yukarı