Gentoo /boot doesn’t like an EFI partition sorunu

Katılım
2 Ocak 2021
Mesajlar
600
Çözümler
3
Gentoo kurmaya çalışıyorum, grub-install --target=x86_64-efi --efi-directory=/boot bu komutu yazınca "/boot doesn’t like an EFI partition." bu hatayı veriyor. Yardım edereseniz sevinirim.
 
KS
YeniKullaniciyim
Katılım
2 Ocak 2021
Mesajlar
600
Çözümler
3
Legacy sistem mi kullanıyorsunuz?

UEFI.
Grubu yüklemeye çalıştığın /boot dizini bir EFI disk bölümüne benzemiyor diyor. Eğer oluşturmadıysan, ayrı bir EFI disk bölümü oluşturup bunu /boot olarak bağlayacaksın ve Grubu buraya kuracaksın.

Normal de /boot dizinine farklı bir bölüm bağlamıştım uefi bölümünü mü oraya bağlıyım yani şunun gibi mi mount /dev/sdX /boot
 
KS
YeniKullaniciyim
Katılım
2 Ocak 2021
Mesajlar
600
Çözümler
3
FAT32 şeklinde format attığınızı varsayıyorum, Mount ederken siz muhtemelen rehberdekine bakıp Arch veya Gentoo bölümünü Mount etmişsiniz(arkadaşın Arch kullandığını ve önceden EFI bölümü olduğunu önceki konudan biliyorum). Bir daha Mount edip tekrar deneyin.

Yok dikkat ettim. Ve Dual olduğu için EFI bölümüne format atmadım.
 
KS
YeniKullaniciyim
Katılım
2 Ocak 2021
Mesajlar
600
Çözümler
3
Fat32/Ext2 şeklinde format attığınızı varsayıyorum, Mount ederken siz muhtemelen rehberdekine bakıp Arch veya Gentoo bölümünü Mount etmişsiniz(arkadaşın Arch kullandığını ve önceden EFI bölümü olduğunu önceki konudan biliyorum). Bir daha Mount edip tekrar deneyin.

Ve EFI bölümünü bir yere Mount etmedim ama 100M'lik bir bölüm vardı onu /boot a Mount ettim.
 
Yukarı