GRUB silinen UEFI bilgisayara tekrar GRUB yükleme

lavanta

Hectopat
Katılım
27 Aralık 2013
Mesajlar
235
Yer
Ankara
Arkadaşlar Windows 10 yüklü Dell Vostro 3501 dizüstü bilgisayara Dual Boot Linux Mint kurdum. Sonra da GRUB menüyü ayarlayayım derken işler karıştı ve batırdım. Windows 10'dan Boot edip UEFI'deki Windows hariç diğer girişleri sildim. Şimdi sadece Windows 10 çalışıyor. Linux kendi sürücüsünde duruyor ancak artık GRUB ve Boot olmadığından açılmıyor. Bunu nasıl düzeltebilirim?
 

Ali998

Centipat
Katılım
27 Ağustos 2020
Mesajlar
2.391
Çözümler
21
Yer
Assembly kursunda
Live USB'den boot et ve şunu yap:
sudo mount /dev/sdaX /mnt && sudo chroot /mnt bash
Ardından şu komutları gir:
sudo mount /dev/sdaX /boot && sudo apt install os-prober ntfs-3g && grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB && grub-mkconfig -o /boot/grub/grub.cfg
 
KS
lavanta

lavanta

Hectopat
Katılım
27 Aralık 2013
Mesajlar
235
Yer
Ankara
İlginize teşekkürler ancak sorunu çözemedim ve yeniden kurdum. Kurulumdan sonra güncelleme yaptım ve bu sefer de Grub menüde Windows çıkmıyor.
 
KS
lavanta

lavanta

Hectopat
Katılım
27 Aralık 2013
Mesajlar
235
Yer
Ankara
Sistemi çalışan ortam ile aç, boot-repair kurulu gelir, bununla önyükleyici onarımı yap. Bu şekilde genellikle çoklu açılış sorunları da çözülüyor.
SSD diskin yazma korumalı olduğu gibi bir hata mesajı verdi.

Bir de boot repair'den sonra Grub'da Linux Mint yerine Ubuntu yazıyor.
sudo update-grub
Ve sudo os-prober komutlarını denediniz mi?
Evet. Sorun devam ediyor.
 
Son düzenleme:

dakovey

Hectopat
Katılım
3 Temmuz 2017
Mesajlar
1.030
Makaleler
1
Çözümler
5
Bir de Boot Repair'den sonra Grub'da Linux Mint yerine Ubuntu yazıyor.

Birkaç kez bilgisayarı yeniden başlattığınızda bu sorun çözülecektir. Hatta sorun bile değil.

Evet. Sorun devam ediyor.

Boot-Repair'i çalıştırdıktan sonra en son aşamada çıktıları forumlarda paylaşmak için tıklayın benzeri bir uyarı çıkıyor. Bu butona tıklayıp çıktıları buraya atarsanız iyi olur. Bir de Boot-Repair uygulamasını çalıştırmadan Windows farklı diske kuruluysa bağlayın lütfen.
 
KS
lavanta

lavanta

Hectopat
Katılım
27 Aralık 2013
Mesajlar
235
Yer
Ankara
Birkaç kez bilgisayarı yeniden başlattığınızda bu sorun çözülecektir. Hatta sorun bile değil.



Boot-Repair'i çalıştırdıktan sonra en son aşamada çıktıları forumlarda paylaşmak için tıklayın benzeri bir uyarı çıkıyor. Bu butona tıklayıp çıktıları buraya atarsanız iyi olur. Bir de Boot-Repair uygulamasını çalıştırmadan Windows farklı diske kuruluysa bağlayın lütfen.
Eve gidince deneyeyim. Diz üstünde tek SSD var. UEFI sistemde kurulum yaptım ayrı sürücülere.
Boot-Repair'i çalıştırdıktan sonra sorun çözüldü.
 
Son düzenleme:

Yeni konular

Yukarı